<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<script>
        dataLayer =  [{"make_name":["Mercedes-Benz"],"make_seo_name":["mercedes-benz"],"model_name":["GLB Class"],"model_seo_name":["glb-class"],"vcat_name":["SUVs","Luxury Cars"],"vcat_seo_name":["suvs","luxury"],"tags":["spy-shot","luxury-cars","electric-cars","videos","youtube"]}] ;
                (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window, document, 'script', 'dataLayer', 'GTM-M73XHX4');
    </script>
<title>2021 Mercedes-Benz EQB spy shots and video</title>
<meta name="description" content="Mercedes-Benz is planning battery-electric versions of both the GLA and GLB, with a prototype for the latter spotted testing."> <link rel="canonical" href="https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video">
<script type="application/ld+json">
{"@context":"https://schema.org","@type":"WebPage","@id":"https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video","url":"https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video","isPartOf":{"@type":"WebSite","@id":"https://www.motorauthority.com/#site"},"breadcrumb":{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.motorauthority.com/news","name":"News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.motorauthority.com/news/spy-shot","name":"Spy Shots"}}]},"mainEntity":{"@type":"NewsArticle","@id":"https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video#this","url":"https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video","headline":"2021 Mercedes-Benz EQB spy shots and video","datePublished":"2020-07-14T14:00:00+0000","dateModified":"2020-07-14T10:00:49+0000","description":"Mercedes-Benz is planning battery-electric versions of both the GLA and GLB, with a prototype for the latter spotted testing.","author":{"@type":"Person","name":"Viknesh Vijayenthiran","jobTitle":"Editor","image":"https://images.hgmsites.net/tny/avatar-image-for-viknesh_100308679_0.jpg","url":"https://www.motorauthority.com/writer/10001739_viknesh-vijayenthiran"},"publisher":{"@type":"Organization","@id":"https://www.motorauthority.com/#organization"},"articleSection":"Spy Shots","keywords":"Spy Shots","image":{"@type":"ImageObject","@id":"https://images.hgmsites.net/lrg/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290_l.jpg#this","url":"https://images.hgmsites.net/lrg/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290_l.jpg","caption":"2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien","description":"","width":1024,"height":637,"uploadDate":"2019-12-11T14:03:03+0000"}}}
</script>
<meta property="fb:pages" content="196092100393">
<meta property="fb:app_id" content="120432421372">
<meta property="og:site_name" content="Motor Authority">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video">
<meta property="og:title" content="2021 Mercedes-Benz EQB spy shots and video">
<meta property="og:description" content="Mercedes-Benz is planning battery-electric versions of both the GLA and GLB, with a prototype for the latter spotted testing.">
<meta property="og:image" content="https://images.hgmsites.net/hug/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290_h.jpg">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@MotorAuthority">
<meta property="twitter:creator" content="@vikneshvijay">
<meta property="twitter:title" content="2021 Mercedes-Benz EQB spy shots and video">
<meta property="twitter:description" content="Mercedes-Benz is planning battery-electric versions of both the GLA and GLB, with a prototype for the latter spotted testing.">
<meta property="twitter:image" content="https://images.hgmsites.net/hug/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290_h.jpg">
<link href="https://feeds.feedburner.com/Motorauthority2" rel="alternate" type="application/rss+xml" title="Motor Authority News">
<link href="/favicon.ico" rel="shortcut icon" type="image/x-icon">
<link href="/css/app.css?id=52c11cfb4d799163de61" rel="stylesheet">
<script src="/js/head.js?id=6b7e38311ef801f85ac9"></script>
<script async src="https://confiant-integrations.global.ssl.fastly.net/cVCBi6sio0Kr78j5IZSJs1SQ8No/gpt_and_prebid/config.js"></script>
<script async src="https://js-sec.indexww.com/ht/p/184397-144425686721597.js"></script> <script async src="https://cdn.districtm.ca/merge/merge.116297.js"></script> <script async src="https://internetbrands-d.openx.net/w/1.0/jstag?nc=2922-MotorAuthority"></script> <script class="kxct" data-id="sh2lfhber" data-timing="async" data-version="3.0">
                    window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
                    (function(){
                        function retrieve(n){
                            var k='kx'+'internetbrands_'+n, ls=(function(){
                                try {
                                    return window.localStorage;
                                } catch(e) {
                                    return null;
                                }
                            })();
                            if (ls) {
                                return ls[k] || '';
                            } else if (navigator.cookieEnabled) {
                                var m = document.cookie.match(k+'=([^;]*)');
                                return (m && unescape(m[1])) || '';
                            } else {
                                return '';
                            }
                        }
                        Krux.user = retrieve('user');
                        Krux.segments = retrieve('segs').split(',');
                    })();
                </script>
<script async src="https://cdn.krxd.net/controltag/sh2lfhber.js"></script>
<script>
    var gptadslots = [],
        googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
        var gads = document.createElement('script');
        var useSSL = 'https:' === document.location.protocol;
        gads.async = true;
        gads.type = 'text/javascript';
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script>
<script>
        hgmads.setAdUnitBasePath('/2922/motorauthority.tmus');
</script>
<script>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</script>
<script>
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function()
        {q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];
        g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // initialize apstag and have apstag set bids on the googletag slots when they are returned to the page
    apstag.init({
        pubID:'3188',
        adServer:'googletag',
        bidTimeout:2e3
    });


</script>
<script>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</script>
</head>
<body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M73XHX4"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<header>
<div class="nav-container">
<nav>
<div class="mobile-menu"><a class="toggle-device-nav" href="#"></a></div>
<div class="logo"><a href="/" title="Motor Authority"></a></div>
<div class="nav-items">
<ul>
<li><a class="nav-link" data-menu="news" href="/news">News</a></li>
<li><a class="nav-link" href="/news/first-drives">First Drives</a></li>
<li><a class="nav-link" data-menu="auto-shows" href="/news/auto-shows">Auto Shows</a></li>
<li><a class="nav-link" href="/pictures">Photos</a></li>
<li><a class="nav-link" href="/videos">Videos</a></li>
<li><a class="nav-link" href="/news/spy-shot">Spy Shots</a></li>
<li class="desktop-newsletter"><a class="nav-link-btn" data-menu="newsletter" href="javascript:void(0)" title="Newsletter Signup"><img src="/images/envelope.svg" />newsletter</a></li>
</ul>
</div>
<div class="search">
<a class="nav-link-search" data-menu="search" href="javascript:void(0)" title="Search"></a>
</div>
</nav>
</div>
<div class="adv-spacer-top-wraper">
<div class="adv-spacer top ">
<div id="ad-top"></div>
</div>
</div>
<div id="breadcrumbs">
<a href="/">Home</a>
<span> / </span>
<a href="/news">News</a>
<span> / </span>
<a href="/news/spy-shot">Spy Shots</a>
</div>
</header>
<div id="main">
<div class="hidden-slot" id="ad-a-1"></div>
<script>
        window.disqus_domain = 'https://www.motorauthority.com';
        window.disqus_shortname = 'motorauthority';
        window.disqus_key = 'NCF9QGiigz0WoG2RAdgNHu0h4WSUWoLkzI4RZJ6UisUx951obo7XTL1BigknDT9P';
    </script>
<script>
            var xpath = 'appendTo(.sq-block.dynamic-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-side-rail-top',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 6;

            var targets = [];
            targets.push( {'kw': ["d-side-rail-top"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["mercedes-benz,spy-shot,luxury-cars,electric-cars,suvs,luxury,glb-class,videos,youtube"]} );
                                                                targets.push( {'make': ["mercedes-benz"]} );
                                        targets.push( {'model': ["glb-class"]} );
                                                        targets.push( {'vcat': ["suvs,luxury"]} );
                            targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

            
            var callbackFunctions = false;
                            callbackFunctions = [];
                                    var callbackFunction = new hgmads.CallbackFunctionContainer('', "hgmads.refreshOnScroll", "", 'true', 'slotRenderEnded', 'true');
                    callbackFunctions.push(callbackFunction)
                                    var callbackFunction = new hgmads.CallbackFunctionContainer('', "hgmads.disableByMediaQuery", "(max-width: 440px)", 'true', 'renderDynamicAds', 'true');
                    callbackFunctions.push(callbackFunction)
                            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.sq-block.dynamic-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-side-rail-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-side-rail-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["mercedes-benz,spy-shot,luxury-cars,electric-cars,suvs,luxury,glb-class,videos,youtube"]} );
                                                                targets.push( {'make': ["mercedes-benz"]} );
                                        targets.push( {'model': ["glb-class"]} );
                                                        targets.push( {'vcat': ["suvs,luxury"]} );
                            targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

            
            var callbackFunctions = false;
                            callbackFunctions = [];
                                    var callbackFunction = new hgmads.CallbackFunctionContainer('', "hgmads.disableByMediaQuery", "(max-width: 440px)", 'true', 'renderDynamicAds', 'true');
                    callbackFunctions.push(callbackFunction)
                            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-spacer.dynamic)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'news-letter-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["news-letter-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["mercedes-benz,spy-shot,luxury-cars,electric-cars,suvs,luxury,glb-class,videos,youtube"]} );
                                                                targets.push( {'make': ["mercedes-benz"]} );
                                        targets.push( {'model': ["glb-class"]} );
                                                        targets.push( {'vcat': ["suvs,luxury"]} );
                            targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                            wayPointConfig = {fetchMarginPercent: '200%', renderMarginPercent: '150%'};
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-container .adv-spacer-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-top_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-top_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["mercedes-benz,spy-shot,luxury-cars,electric-cars,suvs,luxury,glb-class,videos,youtube"]} );
                                                                targets.push( {'make': ["mercedes-benz"]} );
                                        targets.push( {'model': ["glb-class"]} );
                                                        targets.push( {'vcat': ["suvs,luxury"]} );
                            targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [1280, 600] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[728,90]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-container .adv-spacer-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-bottom_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-bottom_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["mercedes-benz,spy-shot,luxury-cars,electric-cars,suvs,luxury,glb-class,videos,youtube"]} );
                                                                targets.push( {'make': ["mercedes-benz"]} );
                                        targets.push( {'model': ["glb-class"]} );
                                                        targets.push( {'vcat': ["suvs,luxury"]} );
                            targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [1280, 600] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': []  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.video-popup-sidebar .adv-spacer-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-top_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-top_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["mercedes-benz,spy-shot,luxury-cars,electric-cars,suvs,luxury,glb-class,videos,youtube"]} );
                                                                targets.push( {'make': ["mercedes-benz"]} );
                                        targets.push( {'model': ["glb-class"]} );
                                                        targets.push( {'vcat': ["suvs,luxury"]} );
                            targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.video-popup-sidebar .adv-spacer-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-bottom_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-bottom_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["mercedes-benz,spy-shot,luxury-cars,electric-cars,suvs,luxury,glb-class,videos,youtube"]} );
                                                                targets.push( {'make': ["mercedes-benz"]} );
                                        targets.push( {'model': ["glb-class"]} );
                                                        targets.push( {'vcat': ["suvs,luxury"]} );
                            targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<div class="article-block" data-id="1119353" data-url="/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video" data-title="2021 Mercedes-Benz EQB spy shots and video" data-next-id="1117700" data-infinite-scroll="true" data-min-comments="3">
<section class="hero-wrap-parallax parallax-window   gallery " data-image-src-h="https://images.hgmsites.net/hug/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290_h.jpg" data-image-src-l="https://images.hgmsites.net/lrg/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290_l.jpg" data-image-src-m="https://images.hgmsites.net/med/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290_m.jpg" data-image-src-s="https://images.hgmsites.net/sml/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290_s.jpg">
<div class="hero-nav prev"></div>
<div class="hero-nav next"></div>
<div class="overlay"></div>
<div class="hero-inner-wrap">
<div class="left-col">
<header class="title-wrap">
<h1 class="article-title"><span>2021 Mercedes-Benz EQB spy shots and video</span></h1>
<div class="portrait-wrapper">
<a href="/writer/10001739_viknesh-vijayenthiran" class="portrait">
<img src="https://images.hgmsites.net/sml/avatar-image-for-viknesh_100308679_s.jpg" alt="Viknesh Vijayenthiran">
</a>
</div>
<a href="/writer/10001739_viknesh-vijayenthiran" rel="author" class="by-line">
Viknesh Vijayenthiran
</a>
<time datetime="2020-07-14T14:00:00+0000">
July 14, 2020
</time>
<a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment Now!</span>
</a>
<div class="gallery-btn" data-article-id="1119353">
<span class="gallery-icon"></span>
View Gallery
</div>
</header>
</div>
<div class="right-col"></div>
</div>
</section>
<div class="article-wrap">
<div class="left-col">
<div class="highres-gallery">
<div class="highres-gallery-wrapper">
<div class="item gallery-image" data-image-id="100728290">
<img data-id="100728290" src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 600w, https://cimg2.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 400w, https://cimg2.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 300w, https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728291">
<img data-id="100728291" src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" srcset="https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 600w, https://cimg3.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 400w, https://cimg3.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 300w, https://cimg3.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 200w, https://cimg3.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728292">
<img data-id="100728292" src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" srcset="https://cimg0.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 600w, https://cimg0.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 400w, https://cimg0.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 300w, https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728293">
<img data-id="100728293" src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" srcset="https://cimg1.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 600w, https://cimg1.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 400w, https://cimg1.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 300w, https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728294">
<img data-id="100728294" src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 600w, https://cimg2.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 400w, https://cimg2.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 300w, https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image count count-22">
<span class="primary-color">22</span>
<div>photos</div>
</div>
</div>
</div>
<header class="title-wrap">
<h1 class="article-title"><span>2021 Mercedes-Benz EQB spy shots and video</span></h1>
<div class="portrait-wrapper">
<a href="/writer/10001739_viknesh-vijayenthiran" class="portrait">
<img src="https://images.hgmsites.net/sml/avatar-image-for-viknesh_100308679_s.jpg" alt="Viknesh Vijayenthiran">
</a>
</div>
<a href="/writer/10001739_viknesh-vijayenthiran" rel="author" class="by-line">
Viknesh Vijayenthiran
</a>
<time datetime="2020-07-14T14:00:00+0000">
July 14, 2020
</time>
<a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment Now!</span>
</a>
</header>
<article class="content article-style ">
<section class="article-body">
<p>Mercedes-Benz engineers have been spotted with a prototype for an electric version of the <a href="https://www.motorauthority.com/news/1126279_car-review-2020-mercedes-benz-glb-250-baby-g-class-suv">GLB-Class</a>. The new EV is confirmed as the EQB and will be available sometime in 2021.</p>
<p>Although the prototype looks like the regular GLB, the sealed-off grille and lack of exhaust pipes confirm it as an EV. Earlier testers were also seen with fully covered underbodies.</p><div class="nativo-article-slot"></div>
<p>The GLB is based on the MFA2 platform found in Mercedes' latest compact range. The EQB will feature a battery-electric version of the platform. The platform will also underpin an EQA electric SUV based on the recently revealed <a href="https://www.motorauthority.com/news/1128639_2021-mercedes-benz-gla250-to-cost-37-280-chic-design-comes-standard">second-generation GLA</a>. The first dedicated EV platform from Mercedes will <a href="https://www.motorauthority.com/news/1116134_2021-mercedes-benz-eqs-spy-shots">debut in an EQS sedan</a>.</p>
<p><iframe src="https://www.youtube.com/embed/ly8z95qiZdA" width="560" height="400" frameborder="0"></iframe></p>
<p>As for the EQB's powertrain, expect an electric motor at each axle and around 60 kilowatt-hours of battery capacity for more than 200 miles of range initially. More powertrain options could be added down the line. Trademark filings made by Mercedes with the United States Patent and Trademark Office hint at EQB200, EQB250, EQB320, EQB350 and EQB360 grades.</p>
<p>Mercedes' first volume EV is the <a href="https://www.motorauthority.com/news/1118578_2020-mercedes-benz-eqc-200-mile-luxury-electric-suv-debuts">GLC-based EQC</a> which was originally due to reach showrooms in the United States in 2020 but has <a href="https://www.motorauthority.com/news/1126427_mercedes-benz-eqc-delayed-until-2021">been delayed until 2021</a>. The EQS, EQA and this EQB should also arrive in 2021.</p>
<p>Many automakers in the luxury space are working on electric compact crossovers. Volvo last October launched the <a href="https://www.motorauthority.com/news/1125558_2021-volvo-xc40-recharge-is-company-s-first-ev-and-part-of-larger-push-toward-reduced-emissions">XC40 Recharge</a> and Lexus the following month launched an <a href="https://www.motorauthority.com/news/1124681_first-production-ev-from-lexus-is-the-ux-300e-compact-crossover">electric version of its UX</a> for the Chinese market. France's DS has also just introduced the DS 3 Crossback E-Tense. Soon we'll be able to add Mercedes' EQB and EQA to the list.</p>
</section>
<section class="footer">
<div class="highres-gallery">
<div class="title">
High-Res Gallery:
<a href="#" onClick="hgm.openGallery(1119353, null, 100728290); return false;">
2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien
</a>
</div>
<div class="highres-gallery-wrapper">
<div class="item gallery-image" data-image-id="100728290">
 <img class="lazy" data-id="100728290" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 600w, https://cimg2.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 400w, https://cimg2.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 300w, https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728290.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728291">
<img class="lazy" data-id="100728291" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 600w, https://cimg3.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 400w, https://cimg3.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 300w, https://cimg3.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 200w, https://cimg3.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728291.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728292">
<img class="lazy" data-id="100728292" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 600w, https://cimg0.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 400w, https://cimg0.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 300w, https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728292.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728293">
<img class="lazy" data-id="100728293" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 600w, https://cimg1.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 400w, https://cimg1.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 300w, https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728293.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728294">
<img class="lazy" data-id="100728294" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 600w, https://cimg2.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 400w, https://cimg2.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 300w, https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728294.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100728295">
<img class="lazy" data-id="100728295" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728295.jpg" alt="2021 Mercedes-Benz EQB spy shots - Photo credit: S. Baldauf/SB-Medien" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728295.jpg 600w, https://cimg3.ibsrv.net/ibimg/hgm/400x225-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728295.jpg 400w, https://cimg3.ibsrv.net/ibimg/hgm/300x169-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728295.jpg 300w, https://cimg3.ibsrv.net/ibimg/hgm/200x113-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728295.jpg 200w, https://cimg3.ibsrv.net/ibimg/hgm/150x84-1/100/728/2021-mercedes-benz-eqb-spy-shots--photo-credit-s-baldauf-sb-medien_100728295.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
</div>
</div>
</section>
<div class="article-tags">
<h3>Tags:</h3>
<a href="/news/electric-cars">Electric Cars</a>
<a href="/news/luxury-cars">Luxury</a>
<a href="/news/luxury">Luxury Cars</a>
<a href="/news/glb-class">Mercedes-Benz GLB Class News</a>
<a href="/news/mercedes-benz">Mercedes-Benz News</a>
<a href="/news/spy-shot">Spy Shots</a>
<a href="/news/suvs">SUVs</a>
<a href="/news/videos">Videos</a>
<a href="/news/youtube">youtube</a>
</div>
<div class="article-contribute">
<h3>Contribute:</h3>
<ul>
<li><a href="/aboutus#contact-us">
<i class="icon fas fa-lightbulb"></i> Send us a tip
</a>
<li><a href="/aboutus#contact-us">
<i class="icon fas fa-pencil-alt"></i> Contact the editor
</a>
</ul>
</div>
<section class="comments">
<a href="javascript:void(0)" class="show-comments red-button" data-min="3">
Show Comments
</a>
</section>
<div class="footer-block">
<div id="suggested-articles">
<h3>People who read this, also read:</h3>
<ul>
<li>
<a href="/news/1126385_2021-mercedes-benz-eqa-spy-shots" class="rail-link">2021 Mercedes-Benz EQA spy shots</a>
</li>
<li>
<a href="/news/1086715_2021-nissan-rogue-spy-shots" class="rail-link">2021 Nissan Rogue spy shots</a>
</li>
<li>
<a href="/news/1125163_2021-bmw-6-series-gran-turismo-spy-shots" class="rail-link">2021 BMW 6-Series Gran Turismo spy shots</a>
</li>
<li>
<a href="/news/1121620_2021-porsche-taycan-cross-turismo-spy-shots-video" class="rail-link">2021 Porsche Taycan Cross Turismo spy shots and video</a>
</li>
</ul>
</div>
<div class="share-this">
<h3>Share This Article:</h3>
<a class="social-btn fab fa-facebook-f facebook" href="javascript:void(0)" title="Share this article on Facebook" onclick="window.open('https://www.facebook.com/sharer.php?t=2021%20Mercedes-Benz%20EQB%20spy%20shots%20and%20video&u=https%3A%2F%2Fwww.motorauthority.com%2Fnews%2F1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Facebook', 'https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video');">
</a>
<a class="social-btn fab fa-twitter twitter" href="javascript:void(0)" title="Tweet this article" onclick="window.open('https://twitter.com/intent/tweet?text=2021%20Mercedes-Benz%20EQB%20spy%20shots%20and%20video&url=https%3A%2F%2Fwww.motorauthority.com%2Fnews%2F1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Twitter', 'https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video');">
</a>
<a class="social-btn fab fa-linkedin-in linkedin" href="javascript:void(0)" title="Share this article on LinkedIn" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true?title=2021%20Mercedes-Benz%20EQB%20spy%20shots%20and%20video&url=https%3A%2F%2Fwww.motorauthority.com%2Fnews%2F1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video&source=MotorAuthority.com', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('LinkedIn', 'https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video');">
</a>
<a class="social-btn fab fa-flipboard flipboard" href="javascript:void(0)" title="Flip this article" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?text=2021%20Mercedes-Benz%20EQB%20spy%20shots%20and%20video&url=https%3A%2F%2Fwww.motorauthority.com%2Fnews%2F1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Flipboard', 'https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video');">
</a>
<a class="social-btn far fa-envelope email" href="javascript:void(0)" title="Email this article" onclick="window.open('mailto:?subject=2021%20Mercedes-Benz%20EQB%20spy%20shots%20and%20video&body=Hi%20There%2C%0A%0AI%20thought%20you%20might%20like%20this%20article%3A%0A%0A%20%20%20%202021%20Mercedes-Benz%20EQB%20spy%20shots%20and%20video%0A%20%20%20%20https%3A%2F%2Fwww.motorauthority.com%2Fnews%2F1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video%0A%0ACheers%21%0A', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Email', 'https://www.motorauthority.com/news/1119353_2021-mercedes-benz-eqb-electric-suv-spy-shots-video');">
</a>
</div>
</div>
<div class="footer-block">
<div id="article-author">
<h3>connect with the editor:</h3>
<a href="/writer/10001739_viknesh-vijayenthiran">
<img src="https://images.hgmsites.net/sml/avatar-image-for-viknesh_100308679_s.jpg" class="portrait" alt="Viknesh Vijayenthiran">
</a>
<a href="/writer/10001739_viknesh-vijayenthiran" rel="author" class="by-line">
Viknesh Vijayenthiran - Editor
</a>
<a href="https://twitter.com/vikneshvijay" onclick="hgm.socialFollow('Twitter', 'vikneshvijay'); return true;" target="_blank" title="Viknesh Vijayenthiran’s Twitter profile">
<img class="social" src="/images/twitter.png" alt="Twitter">
</a>
</div>
<div class="follow-us">
<h3>Follow Us Today:</h3>
<a class="social-btn" title="Like us on Facebook" href="https://www.facebook.com/MotorAuthority" target="_blank" onclick="hgm.socialFollow('Facebook', 'MotorAuthority'); return true;">
<span class="fab fa-facebook-f"></span>
</a>
<a class="social-btn" title="Follow us on Twitter" href="https://www.twitter.com/MotorAuthority" target="_blank" onclick="hgm.socialFollow('Twitter', 'MotorAuthority'); return true;">
<span class="fab fa-twitter"></span>
</a>
<a class="social-btn" title="Follow us on Instagram" href="https://www.instagram.com/motorauthority/" target="_blank" onclick="hgm.socialFollow('Instagram', 'motorauthority'); return true;">
<span class="fab fa-instagram"></span>
</a>
<a class="social-btn" title="Subscribe to our YouTube channel" href="https://www.youtube.com/user/motorauthority" target="_blank" onclick="hgm.socialFollow('YouTube', 'motorauthority'); return true;">
<span class="fab fa-youtube"></span>
</a>
<a class="social-btn" title="Follow us on Filpboard" href="https://www.flipboard.com/@MotorAuthority" target="_blank" onclick="hgm.socialFollow('Flipboard', 'MotorAuthority'); return true;">
<span class="fab fa-flipboard"></span>
</a>
</div>
</div>
<div id="used-cars">
<div class="used-cars-label">Related Used Listings: </div><span class="powered-by-tcc"><a href="https://www.thecarconnection.com/used-cars">Powered by The Car Connection</a></span>
<ul>
<li class="used-car">
<a href="https://www.thecarconnection.com/inventory?make=mercedes-benz&amp;model=glb-class&amp;year=2020" title="Used 2020 Mercedes-Benz GLB Class">
<img class="lazy" data-id="100726547" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/726/2020-mercedes-benz-glb-class_100726547.jpg" alt="2020 Mercedes-Benz GLB Class" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/726/2020-mercedes-benz-glb-class_100726547.jpg 1920w, https://cimg3.ibsrv.net/ibimg/hgm/1024x576-1/100/726/2020-mercedes-benz-glb-class_100726547.jpg 1024w, https://cimg3.ibsrv.net/ibimg/hgm/900x506-1/100/726/2020-mercedes-benz-glb-class_100726547.jpg 900w, https://cimg3.ibsrv.net/ibimg/hgm/450x253-1/100/726/2020-mercedes-benz-glb-class_100726547.jpg 450w" sizes="(max-width: 1024px) 313px, calc(100vw - 2rem)">
</a>
<div class="info">
<a class="name" href="https://www.thecarconnection.com/inventory?make=mercedes-benz&amp;model=glb-class&amp;year=2020">
Used 2020 Mercedes-Benz GLB Class
</a>
</div>
<div class="count">
0 cars
</div>
</li>
<li class="used-car">
<a href="https://www.thecarconnection.com/inventory?make=jaguar&amp;model=f-pace&amp;year=2020" title="Used 2020 Jaguar F-Pace">
<img class="lazy" data-id="100709904" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/709/jaguar-f-pace_100709904.jpg" alt="2020 Jaguar F-Pace Checkered Flag Edition" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/709/jaguar-f-pace_100709904.jpg 1920w, https://cimg0.ibsrv.net/ibimg/hgm/1024x576-1/100/709/jaguar-f-pace_100709904.jpg 1024w, https://cimg0.ibsrv.net/ibimg/hgm/900x506-1/100/709/jaguar-f-pace_100709904.jpg 900w, https://cimg0.ibsrv.net/ibimg/hgm/450x253-1/100/709/jaguar-f-pace_100709904.jpg 450w" sizes="(max-width: 1024px) 313px, calc(100vw - 2rem)">
</a>
<div class="info">
<a class="name" href="https://www.thecarconnection.com/inventory?make=jaguar&amp;model=f-pace&amp;year=2020">
Used 2020 Jaguar F-Pace
</a>
</div>
<div class="count">
718 cars
</div>
</li>
<li class="used-car">
<a href="https://www.thecarconnection.com/inventory?make=land-rover&amp;model=discovery-sport&amp;year=2020" title="Used 2020 Land Rover Discovery Sport">
<img class="lazy" data-id="100701782" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/701/land-rover-discovery-sport_100701782.jpg" alt="2020 Land Rover Discovery Sport" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/701/land-rover-discovery-sport_100701782.jpg 1920w, https://cimg2.ibsrv.net/ibimg/hgm/1024x576-1/100/701/land-rover-discovery-sport_100701782.jpg 1024w, https://cimg2.ibsrv.net/ibimg/hgm/900x506-1/100/701/land-rover-discovery-sport_100701782.jpg 900w, https://cimg2.ibsrv.net/ibimg/hgm/450x253-1/100/701/land-rover-discovery-sport_100701782.jpg 450w" sizes="(max-width: 1024px) 313px, calc(100vw - 2rem)">
</a>
<div class="info">
<a class="name" href="https://www.thecarconnection.com/inventory?make=land-rover&amp;model=discovery-sport&amp;year=2020">
Used 2020 Land Rover Discovery Sport
</a>
</div>
<div class="count">
846 cars
</div>
</li>
</ul>
</div>
<div id="most-popular">
<div class="head-bar">
<h3>Most Popular This Week</h3>
<div class="pagination-container">
<div class="swiper-prev">&lt;</div>
<div class="swiper-counter"></div>
<div class="swiper-next">&gt;</div>
</div>
</div>
<div class="swiper-container">
<div class="swiper-wrapper">
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/jeep-wrangler-rubicon-392-concept_100752122_m.jpg">
</div>
<div class="date">
July 13, 2020
</div>
<div class="title">
<a href="/news/1128831_jeep-wrangler-concept-with-450-horsepower-v-8-crashes-ford-bronco-reveal">Jeep Wrangler concept with 450-horsepower V-8 crashes Ford Bronco reveal</a>
</div>
<div class="comment">
<div class="text">
<a href="/writer/10009962_joel-feder" rel="author">
Joel Feder - Interactive Content Manager
</a>
</div>
</div>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/teaser-for-2021-ford-bronco-family-debuting-on-july-13-2020_100750821_m.jpg">
</div>
<div class="date">
July 13, 2020
</div>
<div class="title">
<a href="/news/1128801_2021-ford-bronco-reveal-livestream">Watch the 2021 Ford Bronco reveal live, here, now</a>
</div>
<div class="comment">
<div class="text">
<a href="/writer/10009962_joel-feder" rel="author">
Joel Feder - Interactive Content Manager
</a>
</div>
</div>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/lotus-evija-production_100736848_m.jpg">
</div>
<div class="date">
July 11, 2020
</div>
<div class="title">
<a href="/news/1128824_no-street-legal-car-will-be-able-to-catch-the-lotus-evija-from-0-186-mph">No street-legal car will be able to catch the Lotus Evija from 0-186 mph</a>
</div>
<div class="comment">
 <div class="text">
<a href="/writer/10044742_stephen-edelstein" rel="author">
Stephen Edelstein - Contributing Writer
</a>
</div>
</div>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/2020-dodge-challenger_100750619_m.jpg">
</div>
<div class="date">
July 8, 2020
</div>
<div class="title">
<a href="/news/1128751_dodge-won-t-sell-challenger-srt-super-stock-owners-parts-to-make-demon-clones">Dodge won&#039;t sell Challenger SRT Super Stock owners parts to make Demon clones</a>
</div>
<div class="comment">
<div class="text">
<a href="/writer/10054534_kirk-bell" rel="author">
Kirk Bell - Senior Editor
</a>
</div>
</div>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/beechmont-ford-mustang-gt_100751142_m.jpg">
</div>
<div class="date">
July 12, 2020
</div>
<div class="title">
<a href="/news/1128773_ohio-dealership-selling-750-hp-supercharged-2020-ford-mustang-gts-for-45-000">Ohio dealership selling 750-hp supercharged 2020 Ford Mustang GTs for $45,000</a>
</div>
<div class="comment">
<div class="text">
<a href="/writer/10044742_stephen-edelstein" rel="author">
Stephen Edelstein - Contributing Writer
</a>
</div>
</div>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/1970-monteverdi-high-speed-375s-on-jay-lenos-garage_100751445_m.jpg">
</div>
<div class="date">
July 12, 2020
</div>
<div class="title">
<a href="/news/1128817_1970-monteverdi-high-speed-375s-brings-italian-style-american-muscle-to-jay-leno-s-garage">1970 Monteverdi High Speed 375S brings Italian style, American muscle to Jay Leno&#039;s Garage</a>
</div>
<div class="comment">
<div class="text">
<a href="/writer/10044742_stephen-edelstein" rel="author">
Stephen Edelstein - Contributing Writer
</a>
</div>
</div>
 </div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/lamborghini-sian-roadster_100751218_m.jpg">
</div>
<div class="date">
July 11, 2020
</div>
<div class="title">
<a href="/news/1128826_lamborghini-sian-roadster-audi-q4-sportback-e-tron-bmw-m4-this-week-s-top-photos">Lamborghini Sian Roadster, Audi Q4 Sportback E-Tron, BMW M4: This Week&#039;s Top Photos</a>
</div>
<div class="comment">
<div class="text">
<a href="/writer/10001739_viknesh-vijayenthiran" rel="author">
Viknesh Vijayenthiran - Editor
</a>
</div>
</div>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/2021-porsche-911-turbo-with-ducktail-spoiler-spy-shots--photo-credits-baldauf-sb-medien_100751374_m.jpg">
</div>
<div class="date">
July 10, 2020
</div>
<div class="title">
<a href="/news/1126213_2021-porsche-911-turbo-with-ducktail-spoiler-spy-shots-and-video">2021 Porsche 911 Turbo with ducktail spoiler spy shots and video</a>
</div>
<div class="comment">
<div class="text">
<a href="/writer/10001739_viknesh-vijayenthiran" rel="author">
Viknesh Vijayenthiran - Editor
</a>
</div>
</div>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<div class="opacity-background " data-background="https://images.hgmsites.net/med/2021-mercedes-benz-s-class-spy-shots--photo-credits-baldauf-sb-medien_100751396_m.jpg">
</div>
<div class="date">
July 10, 2020
</div>
<div class="title">
<a href="/news/1050931_2021-mercedes-benz-s-class-sedan-spy-shots-and-video">2021 Mercedes-Benz S-Class spy shots and video</a>
</div>
<div class="comment">
<div class="text">
<a href="/writer/10001739_viknesh-vijayenthiran" rel="author">
Viknesh Vijayenthiran - Editor
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</article>
</div>
<div class="right-col ">
<aside>
<ul class="block-list rail-related-list">
<li class="first-block active">
<div class="block-item">
 <a class="block-link" href="/news/1107430_2021-mercedes-amg-gt-black-series-confirmed-with-720-horsepower">
2021 Mercedes-AMG GT Black Series confirmed with 720 horsepower
</a>
<a class="block-cat" href="/news/sport-cars">
Sports Cars
</a>
<span>July 14, 2020</span>
</div>
</li>
<li class="sq-block ">
<div id="right-rail-refreshable"></div>
</li>
<li class="sq-block ">
<div id="ad-a-2"></div>
</li>
<li>
<div class="block-item">
<a class="block-link" href="/news/1128855_fisker-to-go-public-may-use-volkswagen-s-meb-platform-for-ocean-suv">
Fisker to go public, may use Volkswagen&#039;s MEB platform for Ocean SUV
</a>
<a class="block-cat" href="/news/auto-industry">
Industry
</a>
<span>July 14, 2020</span>
</div>
</li>
<li>
<div class="block-item">
<a class="block-link" href="/news/1128854_2021-bmw-ix3-electric-suv-arrives-with-80-kwh-battery">
2021 BMW iX3 electric SUV arrives with 80-kwh battery
</a>
<a class="block-cat" href="/news/luxury-cars">
Luxury
</a>
<span>July 14, 2020</span>
</div>
</li>
<li>
<div class="block-item">
<a class="block-link" href="/news/1128849_ford-bronco-raptor-warthog">
Baja-blitzing Bronco Raptor (or Warthog) may be in the works
</a>
<a class="block-cat" href="/news/suvs">
SUVs
</a>
<span>July 14, 2020</span>
</div>
</li>
<li>
<div class="block-item">
<a class="block-link" href="/news/1128852_how-to-remove-the-ford-broncos-doors-roof">
2021 Ford Bronco guide: How to remove the doors and roof
</a>
<a class="block-cat" href="/news/evergreen">
Evergreen
</a>
<span>July 14, 2020</span>
</div>
</li>
<li>
<div class="block-item">
<a class="block-link" href="/news/1128838_2021-ford-bronco-build-configurations">
5 ways to build your 2021 Ford Bronco
</a>
<a class="block-cat" href="/news/suvs">
SUVs
</a>
<span>July 14, 2020</span>
</div>
</li>
</ul>
</aside>
</div>
</div>
</div>
<div class="ac-floating-trigger" style="margin-top: 20px;"></div>
<div class="adv-spacer side-by-side last-article-marker">
<div class="newsletter-signup  rail-box ">
<h3>Motor Authority Newsletter</h3>
<p>
Sign up to get the latest performance and luxury automotive news, delivered to your inbox daily!
</p>
<form data-pos="square" class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input class="newsletter-email" type="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<button class="red-button newsletter-signup-btn" type="submit">Sign Up Today!</button>
<div class="response_message"></div>
</form>
<p>
I agree to receive emails from Motor Authority. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a>
</p>
</div>
<div id="ad-a-3"></div>
</div>
</div>
<div id="instagram" class="mt-4">
<h2>
<a href="https://www.instagram.com/motorauthority/" target="_blank">
Follow Us on Instagram <span class="instagram-user-name">@motorauthority</span>
</a>
</h2>
<div id="instagram-images" class="flex">
<div class="left">
<img src="" alt="" title="">
</div>
<div class="middle flex wrap">
<img src="" alt="" title="">
<img src="" alt="" title="">
<img src="" alt="" title="">
<img src="" alt="" title="">
</div>
<div class="right">
<img src="" alt="" title="">
</div>
</div>
</div>
<a href="#" class="footer-waypoint-anchor"></a>
<footer>
<div class="footer-content">
<div class="footer-logo">
<a href="/" title="Motor Authority">
<div class="logo-type"></div>
<div class="foot-logo-text">The Luxury and Performance Leader</div>
</a>
</div>
<div class="footer-links">
<div class="footer-link-section1 ma">
<div class="footer-link-section">
<h4>News</h4>
<ul>
<li><a class="foot-link" href="/news/spy-shot">Spy Shots</a></li>
<li><a class="foot-link" href="/news/super-cars">Super Cars</a></li>
<li><a class="foot-link" href="/videos">Videos</a></li>
<li><a class="foot-link" href="/news/concept-cars">Concept Cars</a></li>
<li><a class="foot-link" href="/news/suvs">SUV</a></li>
<li><a class="foot-link" href="/news/hybrid-cars">Hybrids</a></li>
<li><a class="foot-link" href="/news/first-drives">First Drives</a></li>
<li><a class="foot-link" href="/news/racing">Racing</a></li>
<li><a class="foot-link" href="/news/muscle-cars">Muscle Cars</a></li>
<li><a class="foot-link" href="/news/auto-industry">Industry</a></li>
<li><a class="foot-link" href="/news/electric-cars">Electric Cars</a></li>
<li><a class="foot-link" href="/news/luxury">Luxury</a></li>
<li><a class="foot-link" href="/news/technology">Car Tech</a></li>
<li><a class="foot-link" href="/news/features">Features</a></li>
<li><a class="foot-link" href="/news">View All</a></li>
</ul>
</div>
<div class="footer-link-section">
<h4>Auto Shows</h4>
<ul>
<li><a class="foot-link" href="/news/sema">SEMA</a></li>
<li><a class="foot-link" href="/news/chicago-auto-show">Chicago</a></li>
<li><a class="foot-link" href="/news/detroit-auto-show">Detroit</a></li>
<li><a class="foot-link" href="/news/geneva-motor-show">Geneva</a></li>
<li><a class="foot-link" href="/news/los-angeles-auto-show">Los Angeles</a></li>
<li><a class="foot-link" href="/news/new-york-auto-show">New York</a></li>
<li><a class="foot-link" href="/news/frankfurt-auto-show">Frankfurt</a></li>
</ul>
</div>
</div>
<div class="footer-link-section2">
<div class="footer-link-section">
<h4>Media</h4>
<ul>
<li><a class="foot-link" href="/pictures">Photos</a></li>
<li><a class="foot-link" href="/videos">Videos</a></li>
</ul>
</div>
<div class="footer-link-section">
<h4>RSS</h4>
<ul>
<li><a class="foot-link" href="/rss-feeds">All Feeds</a></li>
<li><a class="foot-link" href="https://feeds.feedburner.com/Motorauthority2">Master Feed</a></li>
<li><a class="foot-link" href="https://feeds.feedburner.com/Motorauthority-News">News</a></li>
<li><a class="foot-link" href="https://feeds.feedburner.com/Motorauthority-FirstDrives">First Drives</a></li>
<li><a class="foot-link" href="https://feeds.feedburner.com/Motorauthority-SpyShots">Spy Shots</a></li>
<li><a class="foot-link" href="https://feeds.feedburner.com/Motorauthority-Videos">Videos</a></li>
</ul>
</div>
<div class="footer-link-section">
<div>
<h4>Company</h4>
<ul>
<li><a class="foot-link" href="/aboutus">About Us</a></li>
<li><a class="foot-link" href="/aboutus#contact-us">Contact Us</a></li>
<li><a class="foot-link" href="http://ibauto.tumblr.com/">Press</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/ibterms/">Terms of Use</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/ibterms/supplementalcarrelatedterms/">Disclaimer</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/privacy/privacy-main.html">Privacy Policy</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/privacy/privacy-contact-form.php">Do Not Sell My Personal Information</a></li>
</ul>
</div>
<div class="footer-other-sites">
<h4>Our Other Sites</h4>
<ul>
<li><a class="foot-link" href="https://www.thecarconnection.com/">The Car Connection</a></li>
<li><a class="foot-link" href="https://www.greencarreports.com/">Green Car Reports</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class="footer-social-app-btns">
<section class="social">
<div class="follow-us">
<h3>Follow Us Today:</h3>
<a class="social-btn" title="Like us on Facebook" href="https://www.facebook.com/MotorAuthority" target="_blank" onclick="hgm.socialFollow('Facebook', 'MotorAuthority'); return true;">
<span class="fab fa-facebook-f"></span>
</a>
<a class="social-btn" title="Follow us on Twitter" href="https://www.twitter.com/MotorAuthority" target="_blank" onclick="hgm.socialFollow('Twitter', 'MotorAuthority'); return true;">
<span class="fab fa-twitter"></span>
</a>
<a class="social-btn" title="Follow us on Instagram" href="https://www.instagram.com/motorauthority/" target="_blank" onclick="hgm.socialFollow('Instagram', 'motorauthority'); return true;">
<span class="fab fa-instagram"></span>
</a>
<a class="social-btn" title="Subscribe to our YouTube channel" href="https://www.youtube.com/user/motorauthority" target="_blank" onclick="hgm.socialFollow('YouTube', 'motorauthority'); return true;">
<span class="fab fa-youtube"></span>
</a>
<a class="social-btn" title="Follow us on Filpboard" href="https://www.flipboard.com/@MotorAuthority" target="_blank" onclick="hgm.socialFollow('Flipboard', 'MotorAuthority'); return true;">
<span class="fab fa-flipboard"></span>
</a>
</div>
</section>
</div>
</div>
<div class="copyright">
&copy; 2020 MH Sub I, LLC. All Rights Reserved.
Stock photography by <a href="https://www.izmocars.com/">izmostock.</a>
Read our <a href="//www.internetbrands.com/privacy/cookie-policy.html">Cookie Policy</a>.
</div>
</footer>
<div class="adv-spacer bottom">
<div id="bottom-sticky"></div>
</div>
<div class="adv-body-shift "></div>
<div class="nav-menu" data-menu="news">
<div class="nav-menu-items 3">
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/spy-shot">Spy Shots</a>
<a href="/news/super-cars">Super Cars</a>
<a href="/videos">Videos</a>
<a href="/news/concept-cars">Concept Cars</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/suvs">SUV</a>
<a href="/news/hybrid-cars">Hybrids</a>
<a href="/news/first-drives">First Drives</a>
<a href="/news/racing">Racing</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/muscle-cars">Muscle Cars</a>
<a href="/news/auto-industry">Industry</a>
<a href="/news/electric-cars">Electric Cars</a>
<a href="/news/luxury">Luxury</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/technology">Car Tech</a>
<a href="/news/features">Features</a>
<a href="/news">View All</a>
</div>
</div>
</div>
<div class="nav-menu" data-menu="auto-shows">
<div class="nav-menu-items 0">
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/chicago-auto-show">Chicago</a>
<a href="/news/detroit-auto-show">Detroit</a>
 </div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/frankfurt-auto-show">Frankfurt</a>
<a href="/news/geneva-motor-show">Geneva</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/los-angeles-auto-show">Los Angeles</a>
<a href="/news/new-york-auto-show">New York</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/sema">SEMA</a>
<a href="/news/auto-shows">View All</a>
</div>
</div>
</div>
<div class="nav-menu" data-menu="newsletter">
<div class="nav-menu-items nav-signup">
<div class="heading">Motor Authority Newsletter</div>
<div>Sign up to get the latest performance and luxury automotive news, delivered to your inbox daily!</div>
<form data-pos="navigation" class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input type="email" class="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<button class="red-button newsletter-signup-btn" type="submit">Sign Up Today!</button>
<div class="response_message"></div>
</form>
</div>
<div class="signup-consent">I agree to receive emails from Motor Authority. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a></div>
</div>
<div class="nav-menu nav-menu-search" data-menu="search" data-engine="001937828977938864696:vfx0s698d2m" data-placeholder="Search Motor Authority...">
<div class="nav-search">
<gcse:searchbox-only enableHistory="true" autoCompleteMaxCompletions="10" autoCompleteMatchType='any' resultsUrl="/searchresults"></gcse:searchbox-only>
</div>
</div>
<div class="device-nav">
<a class="nav-link  cat-link " href="/news">News</a>
<div class="nav-categories">
<a href="/news/spy-shot">Spy Shots</a>
<a href="/news/super-cars">Super Cars</a>
<a href="/videos">Videos</a>
<a href="/news/concept-cars">Concept Cars</a>
<a href="/news/suvs">SUV</a>
<a href="/news/hybrid-cars">Hybrids</a>
<a href="/news/first-drives">First Drives</a>
<a href="/news/racing">Racing</a>
<a href="/news/muscle-cars">Muscle Cars</a>
<a href="/news/auto-industry">Industry</a>
<a href="/news/electric-cars">Electric Cars</a>
<a href="/news/luxury">Luxury</a>
<a href="/news/technology">Car Tech</a>
<a href="/news/features">Features</a>
<a href="/news">View All</a>
</div>
<a class="nav-link " href="/news/first-drives">First Drives</a>
<a class="nav-link  cat-link " href="/news/auto-shows">Auto Shows</a>
<div class="nav-categories">
<a href="/news/chicago-auto-show">Chicago</a>
<a href="/news/detroit-auto-show">Detroit</a>
<a href="/news/frankfurt-auto-show">Frankfurt</a>
 <a href="/news/geneva-motor-show">Geneva</a>
<a href="/news/los-angeles-auto-show">Los Angeles</a>
<a href="/news/new-york-auto-show">New York</a>
<a href="/news/sema">SEMA</a>
<a href="/news/auto-shows">View All</a>
</div>
<a class="nav-link " href="/pictures">Photos</a>
<a class="nav-link " href="/videos">Videos</a>
<a class="nav-link " href="/news/spy-shot">Spy Shots</a>
<li class="mobile-newsletter">
<div class="newsletter-wrapper">
<div class="newsletter-title">Never Miss a Motor Authority Story</div>
<form class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input type="email" class="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<div class="signup-consent">
I agree to receive emails from Motor Authority. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a>
</div>
<button class="red-button newsletter-signup-btn" type="submit">subscribe today</button>
<div class="response_message"></div>
</form>
</div>
</li>
</div>
<script src="/js/vendor.js?id=497cadd5c6e8922bd00c"></script>
<script src="/js/app.js?id=de02cb55c89deb08a968"></script>
<script>
(function(){
        hgm.initArticles();
        hgmads.initFromDeferred();
hgm.initInstagram();
hgm.initSearch();
hgm.initSearch();
}());
</script>
<script src="/js/footer.js?id=a28ce39f85f1249fdb31"></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"fcb635eb66","applicationID":"129456491","transactionName":"MgcAYUMDDUFWAkJaDAtNI1ZFCwxcGA9TRBBIAxBBWAEPVw==","queueTime":0,"applicationTime":360,"atts":"HkAXFwsZHh4VABQJGBgf","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
